jquery2.0放弃ie9以下的版本,亲你准备好了吗

作者:norion时间:2013年5月29日评论次数:0 条

jquery 2.0不在对ie6,7,8三个版本进行支持,亲你准备好了吗?

时至今日,ie低版本已经开始阻碍互联网发展,特别是臭名昭著的ie6,一些前端基于IE6的分析工具,脱离IE6无法运行,还要考虑测试网页兼容性,一把浏览器都要测试一遍,因为多数人都在用,所以做网页时,不得不考虑IE6的用户们,但是时代总是在前进,不适合时代的总是会被淘汰。

很多人是懒得换,装系统自带什么就用什么,现在用360的挺多,那不都不是安全卫士捆绑安装的,装上就用呗,虽然业内人士觉得360挺流氓的,但是360也帮忙降低了ie6的使用率,可以说什么事都有两面性呀。

目前,jquery 2.0已经发布beta版了,当然如果你的网站需要维护对IE8或者低版本(或者是IE9和IE10在兼容模式下运行),你只需要沿用jQuery1.9或者以下版本。

<!--[if lt IE 9]>
	<script src="jquery-1.9.0.js">
<![endif]-->
<!--[if gte IE 9]><!-->
	<script src="jquery-2.0.0.js"><
<![endif]-->

这样做个简单调用,就可以做到兼容,当然即便在jquery 2.0发布后,jquery 团队也将会继续支持和维护1.9,只要IE6/7/8的影响还在就不会停止对其的支持。jquery 团队并未计划未来添加大量的新API,新的功能将会以兼容于1.9与2.0的插件的形式添加进来。

标签:

上一篇: 解决在dom对象中没有getElementsByClassName

下一篇:事非宜 勿轻诺 苟轻诺 进退错

相关文章

评论

发表评论

电子邮件地址不会被公开。 必填项已用*标注